I suggest you ...

Support Ubuntu 18.04

Any idea when support will be coming for this?

38 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    12 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Aleksandar Vinchev commented  ·   ·  Flag as inappropriate

        Did someone could explain why DisplayLink works out of the box with ChromeBit device (for example), but it is pain in the a*s in Ubuntu...

      • Tobias Johansson commented  ·   ·  Flag as inappropriate

        My screens also turns black several times per days with DisplayLink on Ubuntu 18.04. Simultaneously also other connected devices lose connection with my laptop. The driver seems to crash something in the kernel.

      • demiperimetre commented  ·   ·  Flag as inappropriate

        I had the same issues on Ubuntu 18.04 (after using the script https://github.com/AdnanHodzic/displaylink-debian). I plug my external monitor with a VGA chord, it works 5 minutes than the external monitor turns black and the displaylink does not appear when I write lsusb -d 17e9: in a shell. However, the usb plugs still works. Moreover, the ethernet connection does not work.

      • anon commented  ·   ·  Flag as inappropriate

        The -utopic suffix refers to the code name of Ubuntu 14, you should try with `-bionic` for Ubuntu 18.

      • Anonymous commented  ·   ·  Flag as inappropriate

        sudo apt-get install linux-generic-lts-utopic xserver-xorg-lts-utopic libegl1
        -mesa-drivers-lts-utopic xserver-xorg-video-all-lts-utopic xserver-xorg-input-all-lts-utopic
        Reading package lists... Done
        Building dependency tree
        Reading state information... Done
        E: Unable to locate package linux-generic-lts-utopic
        E: Unable to locate package xserver-xorg-lts-utopic
        E: Unable to locate package libegl1-mesa-drivers-lts-utopic
        E: Unable to locate package xserver-xorg-video-all-lts-utopic
        E: Unable to locate package xserver-xorg-input-all-lts-utopic

      • Dimitri Dhuyvetter commented  ·   ·  Flag as inappropriate

        I haven't been able to get DisplyLink monitors to work on a fresh install of Ubuntu 18.04. But I am using Wayland as the standard Gnome 3 isn't working at all for me, just gives me a blank screen...

      • Michael commented  ·   ·  Flag as inappropriate

        I upgraded to 18.04 from 17.10 and the driver worked without reinstall for 3 external monitors on Dell D3100 dock.

      Feedback and Knowledge Base