I suggest you...

Fix the problem where DisplayLinkUserAgent eats 38% of my CPU

OS is windows 10, DLUA is 7.9.6.30.0. This often gets in a state where the user agent sets there using between 35 and 38% of CPU.

63 votes
vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Neil MacMullen shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    60 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Tplanet commented  ·   ·  Flag as inappropriate

        We did notice here that if you move all your files from your desktop to elsewhere else, the CPU usage returns to normal... then, if you move back the files, it stills ok.

        I hate IT

      • c commented  ·   ·  Flag as inappropriate

        Seems to be related to what is actually being rendered. I only get massive CPUs spikes when watching videos.

      • Peter commented  ·   ·  Flag as inappropriate

        Problem still present with newest driver version 8.4 (pre-production)
        Problem with 100% CPU is absolutely clearly related to network DisplayLink. Plug in and have 100% CPU, disconnect and CPU goes back to normal. Need urgently a solution as otherwise no monitor is available.

      • anonymous commented  ·   ·  Flag as inappropriate

        I had the same problem - stopped using my dock entirely. Today I installed the latest driver (December 1, 2017) from the link provided by Alban Rampon above and it worked. It is tagged as "Not for Production," so I was a little concerned. But so far, so good!

      • Matt commented  ·   ·  Flag as inappropriate

        Same issue in high sierra for me also, CPU is running 100%+ on display link manager

      • Patrick commented  ·   ·  Flag as inappropriate

        Im also running high sierra, and same as the post before me, displaylink manager takes up all cpu. internal fan cant even cope

      • Arno Kenis commented  ·   ·  Flag as inappropriate

        Just noticed when connected to a usb-c dock with display link (on the latest driver 85514) on my mac book pro 15" 2,6 GHz Intel Core i7 it eats away 600% of processor resources when videoconferencing. 6/8 cores. That's some performance. We were about to order a few hundred docking stations for our meetingrooms. I ordered an investigation to see where to go now.

      • Dave Ross commented  ·   ·  Flag as inappropriate

        I have been trying to find a solution to this for 9 months...how long can it take?

      • Aron Park commented  ·   ·  Flag as inappropriate

        CPU usage goes up to 50% when XPS13 connected to Dell D3000 docking station.
        runs fine with D3000 disconnected. installed latest Displaylink driver but no luck of fix.

      • Tobin Hall commented  ·   ·  Flag as inappropriate

        DisplayLinkMana uses 100% of a core on a Dell XPS 15 running ubununtu 16.04 with version 1.3.54

      • Dave commented  ·   ·  Flag as inappropriate

        CPU hogging for MacOS/Sierra as well for me. taking between 12 and 30% of my CPU on i7/2.7GHz

        This seems to be a new-ish problem for me in the past few weeks.

      • Manuel commented  ·   ·  Flag as inappropriate

        September 2017, still no fix for the high WUDFHost process load when using displays over DisplayLink. Video playback is choppy and the systes gets crippled from the CPU load.
        Why isn't this fixed yet? This should be a priority

      • Jake commented  ·   ·  Flag as inappropriate

        I have an HP comaq (not sure what exact model) with an ASUS Nividia GeForce 210 silent video card and two monitors hooked up to the VGA and the DVI inputs on the card. do i need DisplayLink if i'm not using a USB cable to connect my monitors?

      • lolek1234 commented  ·   ·  Flag as inappropriate

        same issue here...Systems run on Win 10 professional with DisplayLink 8.1.843.0. As soon as you move your mouse from the internal display to the external display/s that are connected to the usb3 dockingstation the CPU usage on process "WUDFHost process (Windows Driver Foundation -User-mode Driver Framework Host Process)" gets to 20%-80% and the mouse movement is "lagging" hard -> working is not possible (even the i7-6700HQ cant handle the CPU usage of the above mentioned process).
        I´ve tried to install 8.2 Beta 2 08 Mar 2017 to resolve the issue but the problems still exists.
        The newest graphics card driver from Nvidia (from 09.03.17) and chipset drivers are up to date.
        Problem occures on every type of notebook (Dell XPS, Schenker XMG and Lenovo Thinkpad).

        Hopefully this issue gets resolves soon or maybe someone finds the cause and a possible workaround for this issue...

      • Ytaieb commented  ·   ·  Flag as inappropriate

        Same issue here. Windows 10 and DisplayLink 8.1.843.0 (dlidusb.dll). Just moving the mouse generates load on WUDFHost process (Windows Driver Foundation -User-mode Driver Framework Host Process. Are you working on a solution?

      • Tom commented  ·   ·  Flag as inappropriate

        Also seeing this issue with my Surface Book together with a Toshiba dynaDock U3. The surface is on latest Win10 1607 and the driver I currently have installed is 8.1 M0 as of Dec 18th (8.1.843.0)

      ← Previous 1 3

      Feedback and Knowledge Base