I suggest you...

Support linux on ALL your devices

I just purchased a displaylink USB 3 based device; reading the forums I didn't pickup the difference between USB 2.0 being supported and USB 3.0 not being supported. This is nonsense. Content protection on the monitor, I don't care about being able to use protected content; I'd like to just be able to use the monitor I paid for. But no.

I think you should support Linux with USB 3.0 devices to use non-DRM content.

576 votes
Sign in
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    completed  ·  AdminWim (Product Manager, DisplayLink) responded  · 

    Ubuntu is now supported by DisplayLink and can be downloaded from here:


    The Ubuntu driver is designed with open source components and packaging which enables it to be ported and distributed for other linux distros. DisplayLink does not intend to officially support more than Ubuntu. For more information, see our article here:


    If you have further suggestions about Linux support, please raise separate specific feature requests.

    If you have any problems or need support, please use the Linux forum here:

    Please DO NOT use the comments thread to report problems. We have no way of following up on problem reports here. Use the forum instead.


    Sign in
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      • jabodk commented  ·   ·  Flag as inappropriate

        Just finished a fresh install of Ubuntu GNOME 17.04 on a Dell 15 xps9560

        Disabled Nouveau during boot from installation media to be able to start and complete the installation.
        - Edited the boot line and added the following parameter: modprobe.blacklist=nouveau

        Disabled Nouveau on the first boot of the installed system, as described above.

        Once logged in, uninstalled the Nouveau package and edited /etc/default/grub
        - sudo apt-get remove --purge xserver-xorg-video-nouveau (The system will use Intel GPU on subsequent boots until Bumblebee installation)
        - Added the following text to GRUB_CMD_LINUX_DEFAULT: "quiet splash acpi_osi=! acpi_osi=\"Windows 2009\""

        Installed Bumblebee
        - sudo apt-get install bumblebee-nvidia

        Installed the latest Displaylink driver for Ubuntu
        - downloaded from http://www.displaylink.com/downloads/ubuntu.php

        Installed the DKMS framework
        - sudo apt-get install dkms

        Xorg configuration
        - Created a 20-intel.conf file in /etc/X11/xorg.conf.d/ (if the xorg.conf.d is missing, just create it)
        - Added the following lines to the 20-intel.conf file:

        Section "Device"
        Identifier "Intel Graphics"
        Driver "Intel"
        Option "AccelMethod" "sna"
        Option "TearFree" "false"
        Option "TripleBuffer" "true"
        Option "MigrationHeuristic" "greedy"
        Option "Tiling" "true"
        Option "Pageflip" "true"
        Option "ExaNoComposite" "false"
        Option "Tiling" "true"
        Option "Pageflip" "true"

        - Save the file and reboot

        And now i got 3 external monitors working on Dell D3100 Docking Station

      • adam commented  ·   ·  Flag as inappropriate

        lenovo 700 / ubuntu 16lts
        I'm lucky that it's a company pc - otherwise I would be pretty mad that I wasted money on a fancy usb hub.
        When graphic ports (sometimes, but very rarely and in an undeterministic manner) work the graphics is horrbible with tons of artifacts showing at random. Even the jack port doesn't work.

        The drivers are a waste of time and linux support is false marketing!

      • Frank commented  ·   ·  Flag as inappropriate

        I can't get this to work properly with a Dell D3100 docking station and 2 extra screens on linux mint.

        One screen goes haywire and there are many graphical glitches.

        Can you please improve this driver for Linux?

      • Louis Grasset commented  ·   ·  Flag as inappropriate

        What about openSUSE drivers ? Guys please be fair : dev some drivers for all main dist... : Cent, openSUSE, Fedora and Mint...

      • D. Charles Pyle commented  ·   ·  Flag as inappropriate

        Fedora 25 now detects and automatically configures the DisplayLink device on my computer at boot time. Right on the LiveDVD it will light up the monitor and then you will have to use the Displays control panel once you logon to arrange your monitors. I was pleasantly surprised because I have not been able to use this device on any Linux computer without severe problems with stability and an annoying, flickering mouse cursor.

        At any rate, you then will have to copy your working monitors.xml to /etc/skel/.configure and also to /var/lib/gdm/.config/ in order to ensure consistency across the system because Xorg and Wayland still don't know how to arrange multiple monitors' ports correctly. Every time I end up with screen 3 as primary, with the DisplayLink device being set up as screen 2 (off to the right of screen 1) and the other identical monitor to the right of screen 3 as screen 1. They are always scrambled until I manually set the arrangement and save the configuration.

        Unfortuately, if you enable acceleration options or TearFree on a Radeon card, it will then render the DisplayLink device inoperable again until you remove the xorg.conf file that configures those options for the Radeon card. Tried several configurations and nothing has so far worked. So, I just went back to the default auto-configuration. I don't do a whole lot on the Linux side these days any more so I guess I will worry about acceleration later.

      • anonymous commented  ·   ·  Flag as inappropriate



        I currently have VERY expensive USB hubs after buying 4 of the D3100 boxes for our new DELL XPS 15 laptops w/ 32 GB RAM, 1 TB SSD and Nvidia GTX 1050 dedicated cards.

        Using the opensource drivers causes lag, tearing and artifacts. Using the proprietary drivers means the D3100 is basically a USB hub with blank displays.

        Thank goodness I insisted on purchasing these USB hubs for testing by us before ordering for the whole company and our clients. Am currently testing other solutions and am sure we will have viable options before a working version of this hardware is available.

        Charles Williams
        IT Infrastructure & Architect Manager
        Madsack Online GmbH & Co. KG

      • Splix76 commented  ·   ·  Flag as inappropriate

        Please release a Fedora / CentOS driver. Only supporting Ubuntu leaves users with only one desktop choice, and some of us value privacy and won't use Ubuntu.

      • Anders commented  ·   ·  Flag as inappropriate

        when are u planning on fix the issue
        * i cant plugin in usb when laptop is open, i need to lock screen first and then close laptop screen then i can plugin the usb displaylink
        * it also crash a lot so i got rendering in software mode in X

        im running latest version and kernel 3.19
        xserver-xorg 1:7.7+1ubuntu8.1

      • asevans48 commented  ·   ·  Flag as inappropriate

        So I installed your driver (nice that it was released so near the 'release' date of 16.04) but am still seeing major issues. My display link did not have enough slots for the monitors so I am plugging one directly into my laptop (Dell Inspiron 15 core i3 with built in Intel Graphics and 8 gb RAM). RAM and disk space shouldn't be a huge problem I am guessing and I really don't know if DMA or what not is used. What I do know is that the monitors flicker on and off and the driver is still crashing. I am seeing many of the same issues as I experienced when I was using a hacked version of the driver for earlier Ubuntu releases. 2 of my monitors are from Dell, one is the built in laptop screen, and the other is a Samsung.

        Display Link Device: Targus ACP70USZ

        How to recreate the Problem:

        Plug in Display Link
        Plug in Other Monitor
        Install Ubuntu display link driver
        After a while, the monitors start rotating, flickering, and turning off, internet has to be moved to the ethernet port or Wi-Fi card of the Laptop.

        Restart computer

      • KS commented  ·   ·  Flag as inappropriate

        Centos/RHEL 7/6 support ...

        With out that its a waste of time I have the 4in1 and the dock... got it with my XPS.

        Any one getting here should avoid this if using rhel/centos.

      • Gregory Langlais commented  ·   ·  Flag as inappropriate

        I bought a Dell XPS 13 about 3 months ago and installed Ubuntu 16.04 on it. I also purchased the DisplayLink dongle.

        Since I've had the laptop the dongle has never worked for my Sony external monitor. The ethernet functionality works as expected.

        Steps to Reproduce:
        - Install Ubuntu 16.04 on Dell XPS13
        - Plug in DisplayLink dongle
        - Connect monitor cable to dongle

        Expected Behavior:
        Monitor will be recognized by Ubuntu and both laptop screen and external monitor will be usable real estate.

        Actual Behavior:
        First the laptop screen turns off for a few seconds and then comes back on; however, the computer is "frozen" until the monitor cable or dongle is disconnected.

        I have waited patiently for a fix but am really frustrated by not being able to use an external display.

        I'd love to help provide the information needed to get a working driver version.

        Thanks in advance!

      • m_f_ commented  ·   ·  Flag as inappropriate

        And here we go again Windows driver is updated and linux ???
        Can you give an ETA?

      ← Previous 1 3 4 5 6 7 8

      Feedback and Knowledge Base