I suggest you ...

Mojave 10.14 still doesn't work even with driver

Mojave 10.14 cannot find monitor AT ALL - no signs of life, period

10 votes
Vote
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
You have left! (?) (thinking…)
jeanna_email shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
completed  ·  AdminWim (Product Manager, DisplayLink) responded  · 

DisplayLink does work on Mojave with v5.x or later. If you are still having issues, make sure that the DisplayLink kernel extension is enabled as described here:
https://support.displaylink.com/knowledgebase/articles/1188004
If the kext is enabled and it is still not working, please send us a message through the “Contact Us” form on this site. We can’t support you properly through the comments system here.

8 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • Horst Grabosch commented  ·   ·  Flag as inappropriate

    After a one hour journey I reached this point here. Succeeded in every step told here inclusive kext but my DisplayLink-Screen is still black with Mojave 10.14.5 and Asus169B

  • AdminAlban Rampon (Product Manager, USB Docking and Graphics Adapters, DisplayLink) commented  ·   ·  Flag as inappropriate

    @Reiner, The 3rd output on that product is NOT using DisplayLink technology but alternate mode. I suggest you look on Dell support website for Dell D6000 firmware update. If that doesn’t work, create a ticket to DisplayLink tech support as describe just above and we can find another of their firmware version. DisplayLink driver does not control third party technology.

  • Reiner Diedrichsen commented  ·   ·  Flag as inappropriate

    For some reason i never had this problem since the update early last year but since this morning only two of my three displays are working this was never a problem and i cant see any recent update pushed out in the last week or two. Mojave 14.5 with a D6000 dock

  • Lisa commented  ·   ·  Flag as inappropriate

    Mine also doesn't work. I'm running 10.14.4 and I can't get the monitor to show anything.

  • Joel Hocking commented  ·   ·  Flag as inappropriate

    Same here, any help would be greatly appreciated!

    running 10.14.4 and installed display link 5.1 connected Targus Dock, which is a known working Displaylink product, macbook recognizes a USB device connected but no monitor extension options are shown. the secondary display does not come on at all.

  • Matt commented  ·   ·  Flag as inappropriate

    Same here. Running 10.14.3. Very frustrating. I purchased the monitor about 3 months ago and was fine waiting for an update, but now that another update came out, I'm very frustrated

Feedback and Knowledge Base