I suggest you ...

Conflicts using Nvidia Prime, Displaylink and Ubuntu

I would like to describe conflicts using Nvidia Prime, Displaylink and Ubuntu in my experience.

My environment: Ubuntu 18.10, Nvidia GTX 1070 (nvidia-driver-415), Displaylink 5.1, Asus MB168B+ (USB monitor), laptop Gigabyte Aero15x.

If I try to login with nvidia profile activated and anything connected in USB ports (even only a mouse), I will face a login loop. It only will stop after disconnecting all USB devices, restarting the system and then I'll be able to login into my Ubuntu. Once logged in, I can connect my USB devices and use everything included my second monitor.

If I try to login with intel profile activated. There will be no problems. Displaylink works ok.

Another interesting behavior. If I start up my laptop with all USB devices connected, of course only possible using intel profile; Displaylink will work perfectly. But if instead, during an current session I plug on my external monitor, I will always see blurry and weird definition around the mouse pointer.

If Displaylink could improve this will help lots of Linux users.
Thanks!

9 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Marcio Marins shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    0 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...

      Feedback and Knowledge Base