I suggest you ...

Add support for Ubuntu 16.10

Ubutun 16.10 is just days away and the DisplayLink drivers don't work for it and cause X to crash.

[26700.930972] ------------[ cut here ]------------
[26700.930995] kernel BUG at /build/linux-B4zRAA/linux-4.8.0/mm/usercopy.c:75!
[26700.931021] invalid opcode: 0000 [#2] SMP
[26700.931038] Modules linked in: evdi(OE) nls_iso8859_1 uas usb_storage nvram msr vmnet(OE) vmw_vsock_vmci_transport vsock vmw_vmci vmmon(OE) ccm rfcomm cmac cdc_mbim snd_usb_audio snd_usbmidi_lib cdc_ncm qcserial usb_wwan usbserial qmi_wwan cdc_wdm usbnet uvcvideo mii videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core videodev media btusb btrtl bnep arc4 i2c_designware_platform i2c_designware_core snd_soc_skl snd_soc_skl_ipc snd_soc_sst_ipc snd_soc_sst_dsp snd_hda_ext_core hp_wmi snd_hda_codec_hdmi snd_soc_sst_match snd_soc_core snd_hda_codec_conexant snd_hda_codec_generic snd_compress ac97_bus intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp snd_pcm_dmaengine snd_hda_intel snd_hda_codec kvm_intel snd_hda_core iwlmvm snd_hwdep kvm mac80211 snd_pcm irqbypass iwlwifi intel_cstate
[26700.931393] snd_seq_midi cfg80211 intel_rapl_perf snd_seq_midi_event snd_rawmidi snd_seq snd_seq_device snd_timer joydev input_leds snd serio_raw soundcore shpchp idma64 virt_dma intel_pch_thermal mei_me mei intel_lpss_pci hci_uart btbcm btqca btintel bluetooth soc_button_array intel_vbtn tpm_infineon intel_lpss_acpi intel_lpss acpi_pad hp_wireless intel_hid mac_hid sparse_keymap parport_pc ppdev lp parport ip_tables x_tables autofs4 dm_snapshot dm_bufio algif_skcipher af_alg dm_crypt hid_generic
[26700.931619] evdi: [D] evdi_detect:69 (dev=2) Painter is connected
[26700.931622] evdi: [D] evdi_painter_get_edid_copy:192 (dev=2) 00 ff ff
[26700.931667] usbhid
[26700.931678] crct10dif_pclmul crc32_pclmul ghash_clmulni_intel i915 aesni_intel aes_x86_64 lrw glue_helper ablk_helper cryptd i2c_algo_bit drm_kms_helper psmouse e1000e syscopyarea sysfillrect sysimgblt ptp fb_sys_fops ahci pps_core drm libahci i2c_hid wmi hid pinctrl_sunrisepoint video pinctrl_intel fjes
[26700.931818] CPU: 1 PID: 1653 Comm: ThreadedDrmDevi Tainted: G D OE 4.8.0-19-generic #21-Ubuntu
[26700.931852] Hardware name: HP HP EliteBook Folio 1040 G3/80FA, BIOS N83 Ver. 01.02 03/09/2016
[26700.931884] task: ffff8947d6925880 task.stack: ffff8947408f4000
[26700.931907] RIP: 0010:[<ffffffff8262e537>] [<ffffffff8262e537>] __check_object_size+0x77/0x1dc
[26700.931929] evdi: [D] evdi_detect:69 (dev=1) Painter is connected
[26700.931931] evdi: [D] evdi_painter_get_edid_copy:192 (dev=1) 00 ff ff
[26700.931992] RSP: 0018:ffff8947408f7dd8 EFLAGS: 00010286
[26700.932014] RAX: 000000000000005f RBX: ffff89467b6dc2e8 RCX: 0000000000000000
[26700.932038] RDX: 0000000000000000 RSI: ffff8947f144dc68 RDI: ffff8947f144dc68
[26700.932066] RBP: ffff8947408f7df8 R08: 00000000000e3481 R09: 0000000000000005
[26700.932090] R10: 0000000000000060 R11: 0000000000000ce4 R12: 0000000000000058
[26700.932119] R13: 0000000000000001 R14: ffff89467b6dc340 R15: ffff89467b6dc2b8
[26700.932146] FS: 00007f3828ff9700(0000) GS:ffff8947f1440000(0000) knlGS:0000000000000000
[26700.932175] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[26700.932198] CR2: 0000563efbefdde8 CR3: 000000037966c000 CR4: 00000000003406e0
[26700.932227] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[26700.935710] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
[26700.939150] Stack:
[26700.942340] 0000000000000000 ffff894739db7600 ffff89467b6dc2a0 0000000000000058
[26700.945811] ffff8947408f7eb8 ffffffffc041e27d ffff8947408f7e78 ffff894739db76c8
[26700.945813] ffff8945e5bc5800 ffff894739db7708 00007f3828ff86a0 0000000000000400
[26700.945813] Call Trace:
[26700.945829] [<ffffffffc041e27d>] drm_read+0x17d/0x360 [drm]
[26700.945832] [<ffffffff82771fa0>] ? security_file_permission+0xa0/0xc0
[26700.945835] [<ffffffff82632338>] __vfs_read+0x18/0x40
[26700.945836] [<ffffffff82632a96>] vfs_read+0x96/0x130
[26700.945839] [<ffffffff82633f75>] SyS_read+0x55/0xc0
[26700.945842] [<ffffffff82c9eef6>] entry_SYSCALL_64_fastpath+0x1e/0xa8
[26700.945862] Code: 48 0f 44 d1 48 c7 c6 80 4d 0a 83 48 c7 c1 64 a5 09 83 48 0f 44 f1 4d 89 e1 49 89 c0 48 89 d9 48 c7 c7 00 1a 0a 83 e8 fd 03 f7 ff <0f> 0b e8 12 d6 fb ff 85 c0 75 78 48 89 df e8 a6 2d e4 ff 84 c0
[26700.945864] RIP [<ffffffff8262e537>] __check_object_size+0x77/0x1dc
[26700.945865] RSP <ffff8947408f7dd8>
[26700.946000] ---[ end trace 93958cf71e0e4dd6 ]---

This needs fixing for DisplayLink to be a reliable and serious option for external display support.

3 votes
Sign in
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
James Ray shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →


Sign in
Sign in with: facebook google
Signed in as (Sign out)
  • Peder commented  ·   ·  Flag as inappropriate

    On Dell XPS 15 and Dell D3100 usb docking it worked with 16.04, but on 16.10 it flicks between different graphics modes ending up with an error with an external screen. Using
    DisplayLink USB Graphics Software for Ubuntu
    1.3.52 16 Feb 2017
    Please fix these issues, when you state that 16.10 is supported!

  • am_technix commented  ·   ·  Flag as inappropriate

    Very very slow with Ubuntu 16.10 but I found something on my HP Spectre
    When the internal monitor is ON, it's better. When it is deactivated : the external DisplayLink AOC monitor is unusable... Very strange

    Looking for a solution for this issue

  • Rainer Hahnekamp commented  ·   ·  Flag as inappropriate

    After upgrading to 16.10 it's also not working on my machine. Is there a plan to release an improved version?

  • Stephen Lee commented  ·   ·  Flag as inappropriate

    Peter - sorry, but there's no way that 1.2.65 will support a point release for 16.10. It doesn't even support 16.10, no matter what Wim states. A quick glance at the comments below will show the same.

  • Peter Ries commented  ·   ·  Flag as inappropriate

    Ubuntu 16.04.2 point release with 4.8 kernel is on the way. Will driver 1.2.65 support this Ubuntu version as well?

  • Steve G commented  ·   ·  Flag as inappropriate

    sigh... missing be able to use my external monitor since moving to 16.10 / 1.2.65

  • J-E Casta commented  ·   ·  Flag as inappropriate

    ubuntu 16.10 and displaylink 1.2.65 don't work at all for me either.

    No video, USB ok but probleme with sound card

  • Jose Martin commented  ·   ·  Flag as inappropriate

    ubuntu 16.10 and displaylink 1.2.65 don't work at all for me either.

    The worst thing is that downgrading back to 1.1.62 doesn't work!

  • Maxime Lilou commented  ·   ·  Flag as inappropriate

    How could you say that this task is completed? You cannot claim that you have support for 16.10. Not sure who did the programming on 1.2.65, but this is a real shame for DisplayLink as a company.

    This 1.2.65 driver in 16.10 is the most unstable and horrible driver ever seen from a professional company. Completely useless. Everything worked just fine in 16.04. But in 16.10 this is a nightmare.

  • Joachim Nilsson (Troglobit) commented  ·   ·  Flag as inappropriate

    Status update: dowgrading to either Elementary OS or Linux Mint, both based on Ubuntu 16.04, with the 1.2.65 driver -- works great! (Only some minor mouse lagging and screen messup, when placing mouse pointer around corners of glxgears window. Otherwise I get ~60 fps without a hitch. Compared to ~1 fps on Ubuntu 16.10)

    So I can only conclude that there are some really nasty things going on with Ubuntu 16.10, which is hardly surprising given how much else is showing how unstable it is. I guess the lesson we can learn from this, is stick with the LTS releases people.

  • Daniel Olsen commented  ·   ·  Flag as inappropriate

    I am experiencing the severe instabilities on Ubuntu 16.10, DL-3100 and Dell XPS 13 (9343) with 1.2.65. Screens keep disappearing and constant crashes. Very poor performance when it works. The setup worked flawlessly for Ubuntu 16.04. Please fix this for 16.10!

  • DantE commented  ·   ·  Flag as inappropriate

    Yea, this fails pretty bad. Just get a blinking cursor. Dell 15 XPS running 16.10 and Unity.

  • Robin Trulssen Bye commented  ·   ·  Flag as inappropriate

    Lenovo X1 Carbon and tried both a Targus and a Lenovo DisplayLink dock. Everything worked with 16.04. Now the external monitor don't work. Lots of errors in dmesg and slow boot times with errors/semi-hangs.

  • Joachim Nilsson (Troglobit) commented  ·   ·  Flag as inappropriate

    I too can attest to the instabilities reported here. I'm so regretting upgrading from 16.04 to this mess. X1 Carbon G1 with Lenovo USB 3.0 dock..

    Will try both downgrading Ubuntu, older displaylink drivers, and even try Debian before I toss it all out for a completely different laptop.

  • Anonnymous commented  ·   ·  Flag as inappropriate


    [ 1575.585198] evdi: [D] evdi_detect:69 (dev=1) Painter is connected
    [ 1575.585199] evdi: [D] evdi_painter_get_edid_copy:192 (dev=1) 00 ff ff
    [ 1575.682231] do_trap: 57 callbacks suppressed
    [ 1575.682234] traps: unity-settings-[2785] trap int3 ip:7fdb8a404241 sp:7ffdbbd0cdd0 error:0 in libglib-2.0.so.0.5000.0[7fdb8a3b4000+110000]
    [ 1576.005122] evdi: [D] evdi_detect:69 (dev=2) Painter is connected
    [ 1576.005125] evdi: [D] evdi_painter_get_edid_copy:192 (dev=2) 00 ff ff
    [ 1576.005317] evdi: [D] evdi_detect:69 (dev=1) Painter is connected
    [ 1576.005319] evdi: [D] evdi_painter_get_edid_copy:192 (dev=1) 00 ff ff
    [ 1576.605887] compiz[2934]: segfault at 20 ip 00007f629f4d434c sp 00007ffebb0bcb40 error 4 in libunityshell.so[7f629f0da000+5df000]

  • Anonnymous commented  ·   ·  Flag as inappropriate

    The 1.2.65 driver is incredible unstable in Ubuntu 16.10. Almost useless. Works for a short period of time, then crashes. Restore. Crash. Restore crash. Sometimes it works for 10 minutes, other times 2 minutes. Moreover the resolution is not set correctly. Please fix this. 1.1.58 worked perfectly on 16.04.

    uname -a

    4.8.0-26-generic #28-Ubuntu SMP Tue Oct 18 14:39:52 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

  • Anonymous commented  ·   ·  Flag as inappropriate

    I have this version (1.2.65). When I boot with an external display corrected Ubuntu says it must start in a low graphics mode.

← Previous 1

Feedback and Knowledge Base