I suggest you ...

macOS High Sierra 10.13.4+ and Mojave 10.14 Early Previews

The driver (DisplayLink Installer 4.1.11) doesn't work anymore withe macOS High Sierra bêta 10.13.4 (17E139) and newer.

2,750 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    TOULEMONDE shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    Update: November 5th
    Dear DisplayLink macOS users,

    DisplayLink has worked for many months to maintain support for its users during the transition from macOS High Sierra to Mojave. While functionality such as Ethernet and audio or charging, where implemented, is unaffected on all releases, display connectivity has been limited on macOS releases 10.13.4, 10.13.5 and 10.13.6.

    macOS 10.14 Mojave with DisplayLink driver v5.0.1 allows you to run up to 4 extended displays with now optional clamshell and mirror modes. Support for rotated displays is also improved.
    DisplayLink driver v5.0.1 is applicable to macOS 10.14 only.
    Driver v5.0.1: http://www.displaylink.com/downloads/file?id=1257

    Should you experience black extended display(s) with only mouse cursor on 10.14. We recommend you use macOS 10.14.2 Beta 1 or newer. We have also left DisplayLink driver v4.3 Beta available to force an AirPlay extended display on these machines if you cannot update to 10.14.2 Beta 1 with DisplayLink driver 5.0.1.
    Driver v4.3 Beta 6: http://www.displaylink.com/downloads/file?id=1184

    Users on High Sierra 10.13.4-10.13.6 should install v4.3.1 for one extended USB display with multiple resolutions through an additional menu via Apple AirPlay.
    An FAQ details how to enable Apple AirPlay with DisplayLink display for extend or mirror mode.
    DisplayLink driver v4.3.1 is applicable to Mac OS X 10.12 and macOS 10.13.
    Driver v4.3.1: http://www.displaylink.com/downloads/file?id=1251
    FAQ: https://support.displaylink.com/knowledgebase/articles/1854724

    We thank you for your extended patience, we continue to value your feedback and support.

    Kind regards,
    Alban

    1976 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • [Deleted User] commented  ·   ·  Flag as inappropriate

        BREAKING NEWS! For what its worth for those Late-year Apple computer owners.

        I just Amazoned the WaveLink and received my boxes and was good-to-go. At that time (a week ago) I was on mac OS Sierra. Life was GREAT! Then I upgraded to mac OS High Sierra. Life became hell. As I do a great deal of video editing and online group client chats this kinda F****d my dreams.

        Here's what I did to resolve the situation. I am now in surf-boarding the WaveLink waves again...HOORAY!

        1. Took a hint from one of the posts here and contacted Apple support. My iMac is a mid 2011 and I was hoping to downgrade to the previous mac OS Sierra. I did not have much hope though as I'd NOT kept a back up of the system. I keep all of my vital stuff in icloud and on my other new MacBook Pro (2017). I didn't think I'd even be able to speak with a live human as my Apple Care was finished years ago.

        2. I got a live human (several actually as the process took most of the day and several calls and recalls) from Australia and New Zealand. I'm a Californian stationed in Singapore so, that's the support I get. I only mention this because I'm now sure how its handled Stateside.

        3. The Apple Care crew was fantastic. They did all the back-checking and by virtue of my serial number were able to track all my history. After I explained what I wanted to do (because upgrading took away certain App and port video usability) and how I'd like to go backwards (they are not too keen on that for obvious reasons but, oblige the customer).

        4. She mentioned I'd be able to go back to the original operating system (can you believe it...Mountain Lion)? I would need to erase everything on my current HD. I was cool with that as I only needed to copy over (to an external WD passport because she said NOT to save on Time Machine).

        5. I did all the SHIFT+OPTION+COMMAND+R stuff and was able to do all the tech stuff. Mind-you, I am not a techie by any stretch. You can probably tell by my babbling here.

        6. Once I erased I went to Disk Utility and low-and-behold it presented me with an option to reload with my original, 2011 operating system. I'm leaving out all the nitty-gritty details as I'm sure most if not all of y'all, here are techies. I do have the original emails from Apple Support (with the links to the How-to's linked-within) if anyone wants me to send them. Send me an email or drop me a PM in my Facebook page (Bill Calhoun).

        7. Once I reloaded OS X I tried to go into the App Store (as directed by support) to upgrade to El Capitan (you've gotta do this first before upgrading to Sierra). You see, once you go back to your very first operating system everything after that is free. No need to pay again as Apple has a record of all your crap. As mentioned I tried but, an error popped up saying I had to have OS X version 8 (or something like that) and I only had version 7.

        8. I called Apple Support back and they sent me another link. Its kinda cool how they quickly get all these links to you. I then grabbed El Capitan and proceeded to TRY and load Sierra. However, because I'm in Singapore and my iTunes account is registered in the USA the IP address flag prevented me from grabbing Sierra.

        9. Back on the phone with Apple (I say this nicely cause it really is a joy to talk with LIVELY Live humans). They helped me through the change of country stuff and explained to me what I'd need to do when going back to the USA. Super cool.

        10. I was finally able to load Sierra, hook up WaveLink again and Wah-Lah!

        Now, if I could only shut off the damn request to upgrade to mac OS High Sierra box I'd be in total heaven.

        As mentioned I went from monitor bliss-to-hell-to-bliss and I can throw you the links (mails) for any late model Apple computer-using peeps. Or you can give Apple a shout-out and see if you can get the same.

        Oh, one note. Apple does not typically allow folks to go from El Capitan to Sierra. I don't quite understand that. So, my case got tossed up to another decision-making bot and the approval was lickity-split. Of course, if you have older operating systems you don't even need to go that high up. Perhaps I could have just stuck with El Capitan and WaveLink would have worked fine but, I decided to go back to the last place WaveLink worked.

        Please also note, I only use my late-model iMac for video editing. As mentioned, I bought a late 2017 MacBook Pro for all my important stuff...for what its worth.

        Good Luck, tribe.

      • Clark commented  ·   ·  Flag as inappropriate

        David - Startech has a Thunderbolt 2-3 solution for this issue. It is an HDMI or DisplayPort to Thunderbolt 2-3 adapter. Since this uses the native architecture, it should be the solution moving forward. Apple also has an adapter (what a surprise) but I won't reward them for this kind of behavior. This kind of thing has happened in the past with Apple. They removed support for perfectly operable Kodak USB products as soon as Kodak went belly up. Meaning the Kodak camera was no longer recognized via USB on my MacBook 2008 in the very next build by Apple. The Kodak body wasn't even cold before Apple threw the Kodak customers under the bus. Anyway, you may want to check out Startech.com and I believe the product number is something like TB32HD24K60 for the Thuderbolt 3 adapter. It sounds like you may have the Thunderbolt 2 but there is an adapter for Thunderbot 2 as well. I hope this helps and good luck!!

      • andrew commented  ·   ·  Flag as inappropriate

        has DisplayLink gotten Apple to acknowledge that this is an issue? If they don't even acknowledge its a problem, then good luck in getting them to fix it!

      • Anonymous commented  ·   ·  Flag as inappropriate

        Eager for this to be resolved. I will soon be looking for another provider for my much needed dual screen display!

      • Eric commented  ·   ·  Flag as inappropriate

        DL is definitively out of business or they don't respect they customers. In their page they still refer Mac OS as a supported platform for their useless products ! What is goin on with this company ?

      • Tim commented  ·   ·  Flag as inappropriate

        Any updates about a fix for High Sierra 10.13.4 would be really helpful, whether it is on this forum or through an listserve.

        I'm going on almost two weeks without extended screen options, which has been very challenging to time-sensitive projects with a lot of data.

      • Doug commented  ·   ·  Flag as inappropriate

        When will we get an update? Are all DisplayLink based connected displays just broken for good? Some guidance would be nice - should I give up and move to something else (throwing away my $300 dock) or is a true fix coming?

      • David Poplar commented  ·   ·  Flag as inappropriate

        Thanks to everyone who's been explaining the problem here.

        I'm starting to think we may not get a fix for this for a while, maybe never.

        So does anyone have any specific recommendations for other docking stations that support dual-monitor extended displays that will work? (I'm working off of a mid-2012 macbook pro retina, so I have the original thunderbolt ports.)

      • Chris Metcalf commented  ·   ·  Flag as inappropriate

        This dock doesn't work on new mac just an FYI to those talking about upgrading to new mac. It doesn't matter who is at fault (Apple or DL). The major issue here is DL not updating us AT ALL since April 2nd. The April 13th 'Update' was just a cut and paste of April 2nd update.

      • Suzane commented  ·   ·  Flag as inappropriate

        Hi!
        The last update on this was provided on April 13th. Any news?
        The 10.13.4 OS upgrade does have security fixes which we would like to have applied asap.
        We are starting to regret having this dock in our environment.

        Regards,

      • Anonymous commented  ·   ·  Flag as inappropriate

        This is really bad, I need a second monitor! I hope you solve this ASAP, but in the future ASUS monitor never more! @calembo2013

      • Hello commented  ·   ·  Flag as inappropriate

        Dont thank my patience any more, give us a solution!!!!!
        I lost my patience!

      • Eric commented  ·   ·  Flag as inappropriate

        5 days since last update from @Alban...
        Do you still have a job at DL ?

      • Ben commented  ·   ·  Flag as inappropriate

        Sadly Clark is correct... Time machine backup restore for me and it was a full day of not working... What a mess...

      • Clark commented  ·   ·  Flag as inappropriate

        Hal - If you don't have a Time Machine backup, which I highly recommend and has saved me on multiple occasions, you can follow the instructions provided by Eamon S in an earlier post on this site. To summarize, I believe you will need to find a major build (10.13.1 for example) and step through the update process until you get to the last known good build (10.13.3). Please see Eamon S post for full details. I hope this helps.

      Feedback and Knowledge Base