I suggest you ...

macOS High Sierra 10.13.4+ and Mojave 10.14 Early Previews

The driver (DisplayLink Installer 4.1.11) doesn't work anymore withe macOS High Sierra bêta 10.13.4 (17E139) and newer.

2,724 votes
Sign in
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    TOULEMONDE shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    Update: September 12th
    Dear DisplayLink macOS users,

    DisplayLink has worked for many months to maintain support for its users during the transition from macOS High Sierra to Mojave. While functionality such as Ethernet and audio or charging, where implemented, is unaffected on all releases, display connectivity has been limited on macOS releases from 10.13.4 through 10.13.6.

    Users with access to Apple 10.14 Mojave previews released since 30th July confirmed full support was restored for multiple extended DisplayLink displays.
    We are performing wide scale testing of v5.0 beta released today against current and upcoming previews to release v5.0 upon general availability of 10.14.
    Driver v5.0 Beta: http://www.displaylink.com/downloads/file?d=191

    Users on High Sierra 10.13.4-10.13.6 should install the newly published v4.3 as the workaround to enable one extended USB display now supports additional resolutions.
    An FAQ details how to enable Apple AirPlay with DisplayLink display for extend or mirror mode.
    DisplayLink driver v4.3 released today is also applicable to Mac OS X 10.12 and other macOS 10.13 versions.
    Driver v4.3: http://www.displaylink.com/downloads/file?d=190

    Some MacBook 2018 models on 10.14 previews may experience black extended display(s) with only mouse cursor. DisplayLink driver v4.3 Beta 6 stays available to force an AirPlay extended display on these machines until a fix is distributed.
    Driver v4.3 Beta 6: http://www.displaylink.com/downloads/file?id=1184

    We thank you for your extended patience, we continue to value your feedback and support.

    Kind regards,


    Sign in
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      • Anonymous commented  ·   ·  Flag as inappropriate

        I did updated to Mojave. And i got disappointed. No Luck. Still black screen on my 3rd Monitor :( Total Disappointment.

      • Ben commented  ·   ·  Flag as inappropriate

        With fourth public beta of Mojave (it's the same as fifth developer beta) combined with DisplayLink driver v4.3 beta 5, I can confirm having working displays again.

        At least for now, limited to three external displays, but trying to get my fourth one working as well.

      • Steve Yang commented  ·   ·  Flag as inappropriate

        Hello, I have a 2018 MacBook Pro 15" with Core i9, I have upgraded the system to Mojave beta 5 but it seems that the driver doesn't work at all.

      • John Morris commented  ·   ·  Flag as inappropriate

        Can anyone on the Mojave preview confirm is screen rotation is working again with displaylink? If not I will hold off upgrading since that is a necessity for me.

      • n commented  ·   ·  Flag as inappropriate

        Any updates for the pre-2011 folks who are tethered to High Sierra and cannot anticipate the Mojave fix? We cant use Airplay so still SOL even with the various workarounds

      • AdminAlban Rampon (Product Manager, USB Docking and Graphics Adapters, DisplayLink) commented  ·   ·  Flag as inappropriate

        Hello, if you have DisplayLink 4.3 beta 5 with Mojave Preview 4 (Beta 5) and are experiencing black external displays with only the mouse cursor even after reinstalling the driver, please create a ticket with your logs as described in https://support.displaylink.com/knowledgebase/articles/755301. We don't have the reproduction internally to analyse yet so logs are necessary to give hints on what could be going wrong.

      • Matt Cramp commented  ·   ·  Flag as inappropriate

        And for those noticing that they can only mirror and the resolution is not adapting to the new screen: we've noticed that AirPlay is interrupting DisplayLink's workaround. If you turn wi-fi off before you plug in, the DisplayLink driver will connect properly; you can then use the AirPlay menu in the notifications area near the clock to use it as an extended screen. (You can turn wi-fi on afterwards.)
        Make sure that a) the DisplayLink driver has been authorised as a system extension in the Security and Privacy system preferences screen, and that the DisplayLinkUserAgent has been approved in the Privacy > Accessibility tab of the same screen.

      • jp commented  ·   ·  Flag as inappropriate

        For all of you on 10.13.6 who are having problems with the v4.3 beta 5 not working with airplay, I followed the tip from Anonymous 7/31 @10:27 and went into system preferences/security/general and checked for software blocked from loading. Sure enough DisplayLink was listed there and as soon as I unblocked it and did a restart the USB display showed up in airplay and worked perfectly. I'm on a late 2012 MacMini I7 2.6 quad core.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Macbook Air, 10.13.6. Ran through all of the steps to install the driver and it's a blank screen. It's being detected by the monitor, but no option to select the monitor from the airplay dropdown so the monitor remains dark. Any ideas?

      • utk commented  ·   ·  Flag as inappropriate

        10.13.6 on v4.3 beta 5 mirrors the display, but does not allow to extend. As mentioned in the post, the resolution too is a problem.

      • Josh commented  ·   ·  Flag as inappropriate

        @RJR I've noticed the solution got unstable on 10.13.6. Sometimes it simply won't airplay to DisplayLink. I usually see this happen when I leave the system locked and the screen goes to stand-by for a while. Then I have to turn the dock station off and on (sometimes multiple times) to get it back to work.

      • DW commented  ·   ·  Flag as inappropriate

        4.3 beta with Mojave Preview 4 (Beta 5) works perfectly for me using two different DisplayLink docking stations on my 2012 MacBook Pro 13. Apple finally saw this as a bug, and while they won't fix it in High Sierra, I wouldn't hesitate to use Mojave at this point, as it is stable.

      • RJR commented  ·   ·  Flag as inappropriate

        Additionally, no longer can connect HDMI cable to independent monitor

      • RJR commented  ·   ·  Flag as inappropriate

        on 10.13.6 the solution above no longer works, the AirDisplay no longer allows you to select a monitor

        Anyone have any idea on how to fix this?

      • Vincent commented  ·   ·  Flag as inappropriate

        I am using macOS 10.13.6 and v4.3 beta 5 and a Dual-4K Docking Station from StarTech.com (DK30A2DH). I get on startup the message "DisplayLink Graphics Driver is running in clone mode". Both displays show the cloned built-in display, but I don't get the option to use them as separate displays. Nothing happens when I click on "AirPlay link to: DisplayLink" as described in the FAQ. If I connect the device after the login as described in the FAQ I still get the message, but there is no DisplayLink to select for AirPlay.

      • Arthur commented  ·   ·  Flag as inappropriate

        Mojave developpers beta 5 here (18A347e), and still getting blank screen with the cursor. The kernel extension consent is disabled, so it's not the issue, and this is a fresh macOS install. (`spctl kext-consent disable` in recovery). Since everything is working for some user, this is not an Apple issue anymore, but definitely a bug in the drivers. Fix your crap, and track the bugs/resolution correctly: it's getting ridiculous.

      • Anonymous commented  ·   ·  Flag as inappropriate

        All is working with beta 4 of Mojave and beta 5 of displaylink drivers.
        Extended displays are back. Thanks!

      • Jan commented  ·   ·  Flag as inappropriate

        MacBook Pro w. TB 13" 2018, Mojave beta 4 (public) and
        2 extended Displays are back, but one is not recognized correctly, the resolution can not be adjusted.
        Tested with different screens and cables.

      Feedback and Knowledge Base