I suggest you...

Repeatedly disconnecting and reconnecting (STILL)

I'm running an ASUS ROG G56jk-EB72 Gaming Laptop with the latest version of Windows 10 (As of 11/12/2015) 64-Bit. CPU: Intel (R) HD Graphics 4600 & GPU: Nvidea GeForce GTX 850M. Trying to project onto two additional Insignia displays using two Targus USB 3.0 to HDMI HDTV Video Adapter. So I spent about $300 for the displays and $160 on the video adapters and this doesn't even work. I am beyond frustrated. All of my drivers are up to date. I followed the steps as instructed by the troubleshooting page; "How to fix your DisplayLink product from repeatedly disconnecting and reconnecting, or freezing" and still nothing seems to work. Does anybody understand what is happening and/or why? And does anybody have the same issues and/or find a solution to this issue?

Please help

1 vote
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Alex Harvey shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Alex commented  ·   ·  Flag as inappropriate

        They always close these issues real fast. They do not want you to know that these monitors no longer work with windows 10. I have had problems on two different PCs since windows 8 with mine and it still don't work. I'm hate to throw things I never used away but, they stole my money plain and simple. Buyer beware as there is still no solution for at least the last 5 years!

      Feedback and Knowledge Base